GTAMP.com

Grand Theft Auto Multiplayer
It is currently Tue Dec 11, 2018 1:03 pm

All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Tue Mar 29, 2011 11:01 pm 
Offline
User avatar

Joined: Fri Apr 24, 2009 9:43 pm
Posts: 515
Location: Estonia
At work i often read my emails with mobile, and when GTAMP forum sends me notification about new post in my (or any) thread and displays direct link to the thread and last post,and when i try to open the link, it sends me to some error page and requires to log in.

This makes no sense. Because the forum is public, all threads are public and when im trying to access last post in some thread quickly, it just doesn't let me.

Why i have to log in to see latest new post?
It doesn't make any sense.


Sektor, can you please fix it?

_________________
Always wear safety glasses while programming.


Top
 Profile  
 
PostPosted: Wed Mar 30, 2011 1:08 am 
Offline
Boss
User avatar

Joined: Tue Mar 04, 2008 6:51 am
Posts: 1345
Location: GTAMP.com
Yes that is pretty stupid. The second link in the email is a a link to the forum that doesn't require login, so you can click that instead but that will take you to the first page of the thread.

The first link requires logging in since it needs to know when you last visited.

A link to the actual post that was updated or the last page would be useful.


Top
 Profile  
 
PostPosted: Wed Mar 30, 2011 2:06 am 
Offline
User avatar

Joined: Fri Apr 24, 2009 9:43 pm
Posts: 515
Location: Estonia
Yes, maybe there is some patch or something, that would allow it.
Or you could DIY.

Actually i can go to last page but because my phone is so old and with small screen (with very poor web support) it cant even display user/psw boxes. And i have to click many many times, until it gets to last post.
ca
But it n display gmail user/psw boxes and even logs in lol.

It's samsung sgh-x500.
Time to upgrade soon.

_________________
Always wear safety glasses while programming.


Top
 Profile  
 
PostPosted: Wed Mar 30, 2011 2:58 am 
Offline
Boss
User avatar

Joined: Tue Mar 04, 2008 6:51 am
Posts: 1345
Location: GTAMP.com
I edited /forum/includes/functions_posting.php

I changed U_TOPIC from "/viewtopic.$phpEx?f=$forum_id&t=$topic_id" to "/viewtopic.$phpEx?p=$post_id#$post_id".

I left U_NEWEST_POST as "/viewtopic.$phpEx?f=$forum_id&t=$topic_id&p=$post_id&e=$post_id". I'll edit the descriptions to make it clear that this one needs you to login.


Top
 Profile  
 
PostPosted: Tue Apr 26, 2011 9:43 pm 
Offline
User avatar

Joined: Fri Apr 24, 2009 9:43 pm
Posts: 515
Location: Estonia
Thank you Sektor. I got a reply in ScrPad topic,decided to try the link in email and it sent me almost to the end of the topic.

Good enough.

_________________
Always wear safety glasses while programming.


Top
 Profile  
 
PostPosted: Tue Apr 26, 2011 9:50 pm 
Offline
Boss
User avatar

Joined: Tue Mar 04, 2008 6:51 am
Posts: 1345
Location: GTAMP.com
It still needs improvements and now it gives you two links to the exact same URL. You also won't get any new emails until you login (it's a feature but not one eveyone wants).


Top
 Profile  
 
PostPosted: Tue Apr 26, 2011 9:58 pm 
Offline
User avatar

Joined: Fri Apr 24, 2009 9:43 pm
Posts: 515
Location: Estonia
Actually there are many links. I clicked second one and it took me to last page..
If you want to view the topic, click the following link:

viewtopic.php?p=4108#4108

Tried on mobile:

_________________
Always wear safety glasses while programming.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group